Resolved

This incident has been resolved.
Posted Nov 02, 2025 - 23:00 EST

Monitoring

We are experiencing a service issue with the SPGCI EDIN platform. Our teams are actively working to restore the services. We appreciate your patience as we work towards resolution. If you require further assistance, please contact us at ci.support@spglobal.com.
Posted Nov 02, 2025 - 22:39 EST
This incident affected: Upstream Solutions (Edin).