Service disruption Notification
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 05:21 EST
Investigating
We are experiencing service issues with streaming capabilities over Commodity Insights Excel Add-in. Our teams are engaged and actively investigating the issue.

If you require further assistance, please contact the Client Service team via ci.support@spglobal.com.
Posted Nov 12, 2024 - 05:16 EST
This incident affected: Core Platforms (Commodity Insights Excel Add-in).