SPGCI - Information Hub Direct Connect (IHDC) - Service Disruption Notification

Resolved

The incident has been resolved. You can now rerun your job to ingest the data.
We appreciate your patience and understanding during this time.

If you require further assistance, please contact the Client Service team via ci.support@spglobal.com.
Posted Jun 23, 2025 - 11:49 EDT

Investigating

We are currently experiencing an outage that has affected the availability and performance of our Information Hub Direct Connect (IHDC) Data manager. Our teams are engaged and actively investigating the issue.

We understand the inconvenience this may cause and appreciate your patience and understanding as we work to resolve the issue promptly. If you require further assistance, please contact the Client Service team via ci.support@spglobal.com.
Posted Jun 23, 2025 - 08:49 EDT
This incident affected: Core Platforms (Commodity Insights APIs).