SPGCI PlattsConnect - Service Disruption Notification

Resolved

This incident has been resolved.
Posted May 28, 2025 - 11:11 EDT

Investigating

We are currently experiencing an issue that is impacting subset of users on SPGCI PlattsConnect Portal. Our team is actively working to resolve these disruptions to ensure a smooth experience for you. Thank you for your patience and understanding.

If you require further assistance, please contact the Client Service team via ci.support@spglobal.com.
Posted May 28, 2025 - 10:57 EDT
This incident affected: Core Platforms (Platts Connect).